This is automatic translation. If you do not like it, switch to English or another language. Thank you for understanding. OK Show original
함유량
루비 업데이트

Ruby는 Easy Redmine을 실행하기위한 전제 조건입니다. 유지되고 지속적으로 업데이트되는 프로그래밍 언어입니다. 어느 정도 시간이 흐르면 ​​Easy Redmine의 새 버전을 사용하려면 Ruby를 업데이트해야합니다. Ruby를 업데이트하면 결과가 달라집니다.이는 우리가 당신에게 몇 가지 지침을 제시하는 이유이며, 따라서 당신은 당신의 구성에 관련된 모든 변화를 잊지 않을 것입니다.

가장 일반적인 문제는 Ruby 업데이트 후에 서버 (유니콘)가 시작되지 않는다는 것입니다.

이 가이드 라인은 Easy Software에서 제공하는 VM의 예와 함께 제공됩니다. 자체 서버에서 수행하기 전에 항상 단계를 확인하십시오.

0 / 백업 만들기

1 / 업그레이드 루비 (rvm 사용)
sudo rvm get head
sudo rvm install ruby-2.6.0-railsexpress
rvm use --default ruby-2.6.0-railsexpress

호환되는 버전을 사용하고 있는지 확인하십시오. 시스템 요구 사항.

2 / bundler & unicorn & puma 설치
보석 설치 bundler 유니콘 푸마

3 / 응용 프로그램 루트 디렉토리로 이동하여 보석 설치
cd APPLICATION_ROOT
번들 업데이트

4 / 쉬운 Redmine 설치
레이크 easyproject : 설치 RAILS_ENV = 생산

5 / 시작 스크립트에서 루비 버전을 변경해야 할 수도 있습니다.
구성은 경로에 있어야합니다 (VM, OS 등의 버전에 따라 다름).

/ etc / systemd / system /푸마 @. 서비스

/ etc / systemd / system /유니콘 @ 서비스

/etc/systemd/system/easy.service

/lib/systemd/system/unicorn.service

예:

...
[서비스]
유형 = 단순
사용자 = 쉬움
WorkingDirectory = / srv / easyredmine / public_html
환경 = RAILS_ENV = 생산
PIDFile = / srv / easyredmine / 실행 / unicorn.pid
ExecStart = / bin / bash -lc 'rvm 2.6.0 unicorn -D -c /etc/unicorn/easyredmine.rb -E production '을 실행하십시오.
...

변경 루비 버전 또는 "default"를 사용하여 저장 한 다음 서비스를 다시 시작하십시오.

그래도 작동하지 않으면, 이 이메일 주소는 스팸봇으로부터 보호됩니다. 당신은 자바 스크립트를 활성화해야합니다. 우리를 보내 stderr.log (유니콘의 오류 로그) 및 생산. 로그

추가 정보
무료 시험판

쉬운 Redmine 10 업그레이드
인기 플러그인 및 기능
신규 및 모바일 디자인
서버 업그레이드
글로벌 클라우드

무료 평가판 시작

30 일 무료 평가판에서 Easy Redmine을 사용해보십시오

모든 기능을 갖춘 30 일, SSL로 보호 된 일일 백업, 지리적 위치에서

or